Mensaje dentro de Servicios Webs

Responder 
#1 - 26/07/2011 6:11:33 Reporta abuso | Link Permanente
amedidape
Fecha de registro: 26/07/2011
0 post en este tema
2 posts en servicios webs
2 posts en todos los foros
¿ASP, Como configurar web.config, alguien ha subido un proyecto ASP?

Responder Citar
Buenas a todos

tengo varios inconvenientes en esto que es algo nuevo para mi:


Es la primera vez que subo un proyecto ASP con base de datos a un hosting con (plataforma WINDOWS obvio).


ahora, en mi ordenador principal sale todo OK con la coneccion localhost y todo utilizando el VISUAL 2005.

en el hosting servidor (www.godaddy.com) ya he creado "segun parece" la base de datos y he subido los archivos respectivamente.


pero cuando le doy en el dominio me sale el siguiente error:





Server Error in '/' Application.
Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load the assembly 'App_Web_ktp6su1m'. Make sure that it is compiled before accessing the page.

Source Error:

Line 1: <%@ page language="VB" autoeventwireup="false" inherits="index, App_Web_ktp6su1m" %>
Line 2:
Line 3: <%@ Register TagPrefix="telerik" Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" %>


Source File: /index.aspx Line: 1

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1




nose a que se deba, segun veo todo esta ok y ya he intentado de mil manera, y pues , recurro a ustedes aver si me podrian brindar alguna ayuda o sugerencia.


he contactado con la central del hosting y han dicho q el problema esta en el archivo web.config , aqui presento como esta configurado la parte de la coneccion



<connectionStrings>
<!-- Agregado -->
<add name="Cnx" connectionString="Server=(Local); Integrated Security=True; DataBase=prestoservices"/>
<add name="NorthwindConnectionString" connectionString="Server=(Local); Integrated Security=True; DataBase=Northwind" providerName="System.Data.EntityClient"/…
<!--<add name="NorthwindConnectionString" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|Da… y|Northwind.mdf;Integrated Security=True;User Instance=True" providerName="System.Data.SqlClient"/>--…
</connectionStrings>



... de veras que estoy a punto de lanzarme del puente... :( por favor si alguien me podria brindar algún pequeño proyecto (de una pequeña consulta a una pequeña base de datos , por ejemplo q solamente llene un lisbox), lo que quiero ver es como es que de verdad se configuran estos archivos para q se puedan visualizar en la web atravez del hosting, para yo subirla y asi descartar errores . si no fuera mucha la molestia por favor


pd: es este el dominio http://sunrisechicago.com/index.aspx

saludos y gracias por su tiempo
Volver arriba

Respuestas
Mostrar de en 15
#2 - 27/07/2011 23:35:48 Reporta abuso | Link Permanente
Josselo Hombre

Fecha de registro: 13/11/2010
1 post en este tema
1 post en servicios webs
80 posts en todos los foros
RE: ¿ASP, Como configurar web.config, alguien ha subido un proyecto ASP?

Responder Citar
No te tires del puente  aun

pueden existir varios problemas al subir a un hosting entre los principales y por lo uqe veo es en tu cadena de conexion

Al crear una base de datos en tu hosting obviamente ya no se comporta como localhost, la razon? no la se puesto que solo pasa con el entorno windows, ahora al momento de crear tu base de datos te brindan una candena de conexion, esa es la que tienes que poner en tu web config. dentro de las etiquetas <connectionStrings>

Otra razon.
al parecer estas utilizando el telerik, aplicacion que hace mas vistosa una pagina en asp.net
tienes que tener cuidado con esta aplicacion pues existen hasta 3 tipos de estos, tanto como para el framework 2.0, 3.0 y creo que ya salio para el 4.0.

Asegurate de subir sus archivos estos se encuentran en la carpeta "Bin"

ojo: no se si lo lei pero te recuerdo que estas usando visual studio 2005, este trabaja con netframework 2.0 , tu telerik no parece ser compatible, revisa eso

si tienes otros problemas  avisa.

Saludos.
Volver arriba


Desarrollo de aplicaciones informaticas | nivel basico y avanzado
Mostrar de en 15