Mensaje dentro de Servicios Webs

Responder 
#1 - 16/06/2008 8:51:42 Reporta abuso | Link Permanente
Mecodi
Usuario no registrado
Error al publicar sitio web

Responder Citar
Hola a tod@s:

No se puede mostrar la página XML 
No se puede ver la entrada XML con la hoja de estilo . Corrija el error y haga clic en el botón Actualizar, o inténtelo de
nuevo más tarde.


--------------------------------------------------------------------------------

No es válido en el nivel superior del documento. Error al
procesar el recurso http://merce/Website1/. Línea 1, Posición
1


Éste es un archivo marcador generado por la herramienta de precompilación y que no se

debería eliminar


La aplicación tiene en su masterpage las directivas para que sea XHTML 1.1:
<%@ Master Language="C#" AutoEventWireup="true" CodeFile="Interface.master.cs"
Inherits
="Interface" %><%@ Register TagPrefix="miscontroles" TagName="controlcabecera"
Src
="~/Controles de
Usuario/ControlCabecera.ascx"
%><%@ Register TagPrefix="miscontroles" TagName="controlpie" Src="~/Controles de
Usuario/ControlPie.ascx"
%>

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "<a
href='http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd'
target='externo'>http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd</a>"
><html xmlns="<a
href='http://www.w3.org/1999/xhtml'

Quité el
<?xml version="1.0" encoding="ISO-8859-1"?>

pues con la meta... charset... que tengo lei en un foro que sirve para XHTML 1.1.
¿Tendré algo más configurado o mal en las directivas del en .aspx?
Si alguien me puede ayudar, tengo que entregar la aplicación compilada y funcionando mañana.
un saludo.
target='externo'>http://www.w3.org/1999/xhtml</a>" xml:lang="sp"> <head runat="server">
<meta http-equiv="Content-Type"
content
="application/xhtml+xml; charset=iso-8859-1" />
<meta http-equiv="content-language"
content
="es" /><meta http-equiv="content-style-type"
content
="text/css" />
<title>Master</title><link href="estilos.css" rel="stylesheet"
type
="text/css" /></head><body>............

Volver arriba

Respuestas
Mostrar de en 15
#2 - 15/03/2013 0:02:24 Reporta abuso | Link Permanente
keFran
Usuario no registrado
RE: Error al publicar sitio web, no actualiza DB solo lectura

Responder Citar
Gracias Bro,me sirvio tu respuesta
Volver arriba

#3 - 29/06/2011 8:17:09 Reporta abuso | Link Permanente
Cesvil
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
las solucion esta aplica pero que sucede si no tengo el IIS como servicio en el servidor? y es el SQL con un JOB que genera estos xml y da este problema.
Bueno el problema fue que un log crecia demasiado y copaba el disco donde se generaban estos xml y por eso resultaba el problema, se limpio el log y se genero de nuevo los xml y listo solucionado... saludos
Volver arriba

#4 - 02/06/2011 4:02:22 Reporta abuso | Link Permanente
Juan Zuruguay
Usuario no registrado
RE: Error al publicar sitio web, no actualiza DB solo lectura

Responder Citar
mira yo tuve el mismo error tratando de publicar mi aplicacion en asp.net mvc 3 , framework 4, pues me decia q no podia act la db porq era de solo lectura,
bien lo q ise fue sencillo, simplemente fui a mi IIS (7.5)  me situe sobre el (direccion)nombre virtual de mi aplicacion y seleccione, luego hice click en Editar Permiso en el Margen superior derecho, y fui a la solapa SEGURIDAD luego busque IIS_IUSRS( El nombre de usuario del iis) y le edite y tilde la opcion de escritura, y eso fue todo.
espero q le sirva a alquien,

Muchas gracias.
Saludos
Volver arriba

#5 - 08/12/2010 21:19:16 Reporta abuso | Link Permanente
ddd
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
sasdas
Volver arriba

#6 - 08/05/2009 0:25:04 Reporta abuso | Link Permanente
loscas
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
Verifica q el Usuario "MERGE\ASPNET" tenga permisos para conectarse
Volver arriba

#7 - 04/01/2009 8:01:09 Reporta abuso | Link Permanente
carlosdaniel
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
hola a mi me esta pasando el mismo problema. Pudiste solucionar? Si es asi mepodrias decir como? Gracias
Volver arriba

#8 - 08/10/2008 18:44:07 Reporta abuso | Link Permanente
ASP.NET
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
Cuando se crea el directorio virtual en el IIS es importante verificar sobre que versión esta corriendo dicho directorio.

Lo que se debe hacer es entrar al IIS dar click derecho sobre el directorio virtual en la opcion de propiedades y revisar en la pestaña de ASP.NET sobre que version del Framework esta corriendo.

Espero les sirva
Volver arriba

#9 - 01/08/2008 11:48:57 Reporta abuso | Link Permanente
Pedro_master_2008
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
No tienes ni puta idea!!! jajajajaja!!!
Volver arriba

#10 - 19/06/2008 21:41:51 Reporta abuso | Link Permanente
Mecodi
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
hola otra vez:
En el IIS, ya puse en la carpeta de la aplicacion, seguridad dedirectorios como nombre de usuario para el acceso anónimo: MERCE\ASPNET
Pero sigue dándome ese error.
Tambiénen el SQL Server 2005 express edition (con el Management studio),añadí, según un foro, el inicio de sesión en el directorioseguridad\Inicios de Sesión. Pero sigue sin funcionar y con ese error.
El Management studio uso Autenticación windows y adjunté las 2 bd, y mis cadenas de conexión son las ya indicadas.
Y ahora me da el error:
No se puede abrir la base de datos predeterminada
del usuario. Error de inicio de sesión.
Error de inicio de sesión del usuario 'MERCE\ASPNET'.
Descripción: Excepción no controlada al ejecutar la solicitud Web actual. Revise el
seguimiento de la pila para obtener más información acerca del error y dónde se originó en el código.

Detalles de la excepción: System.Data.SqlClient.SqlException: No se puede abrir la base de datos predeterminada del usuario. Error de inicio de sesión.
Error de inicio de sesión del usuario 'MERCE\ASPNET'.

Error de código fuente:
Se ha generado una excepción no controlada durante la ejecución de la solicitud Web
actual. La información sobre el origen y la ubicación de la excepción pueden
identificarse utilizando la excepción del seguimiento de la pila siguiente.

Seguimiento de la pila:
[SqlException (0x80131904): No se puede abrir la base de
datos predeterminada del usuario. Error de inicio de
sesión.
Error de inicio de sesión del usuario 'MERCE\ASPNET'.]
System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) +739123
System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
+188
System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler,
SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject
stateObj) +1956
System.Data.SqlClient.SqlInternalConnectionTds.CompleteLogin(Boolean enlistOK) +33
A ver si a alguien se le enciende la bombilla y me ayuda porque a mi ya no se me ocurre qué hacer, gracias y un saludo
Volver arriba

#11 - 19/06/2008 13:50:03 Reporta abuso | Link Permanente
Mecodi
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
Hola:
Pues le di permisos de escritura y sigue el mismo error al loguearse e intentar escribir en ASPNETDB.MDF:

No se pudo actualizar la base de datos "C:\INETPUB\WWWROOT\PFC\APP_DATA\ASPNETDB.MDF" porque es de sólo lectura.

en el web.config tengo:
  <connectionStrings>
   <add name="DatabaseConnectionString1" connectionString="DataSource=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\Database.mdf;IntegratedSecurity=True;User Instance=True"providerName="System.Data.SqlClient"/>
    <addname="DatabaseConnectionString2" connectionString="DataSource=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\ASPNETDB.MDF;IntegratedSecurity=True;User Instance=True"providerName="System.Data.SqlClient"/>
  </connectionStrings>

<membership  defaultProvider="SqlProvider"  userIsOnlineTimeWindow="20">
      <providers>
        <remove name="AspNetSqlProvider" />
        <add name="SqlProvider"
            type="System.Web.Security.SqlMembershipProvider"
            connectionStringName="DatabaseConnectionString2"
            enablePasswordRetrieval="false"
            enablePasswordReset="true"
            requiresQuestionAndAnswer="false"
            applicationName="/" />
      </providers>
    </membership>
En el SQL Server 2005 express edition (con SQL Server Mangement studio) tengo adjuntada mi bd Database.mdf. Lei algo como que tenía que tener tambien la aspnetdb.mdf y en otros sitios que no hacía falta. No se, algo me falta por ahi. Mañana tengo una prueba de la aplicación y el martes la entrega del Proyecto. Tengo que conseguirlo. Sigo. Gracias.
Volver arriba

#12 - 19/06/2008 10:05:16 Reporta abuso | Link Permanente
Indigo Hombre
Fecha de registro: 26/07/2007
1 post en este tema
14 posts en servicios webs
384 posts en todos los foros
RE: Error al publicar sitio web

Responder Citar
Hola,

prueba a darle permisos de escritura a la carpeta APP_DATA. No se si te funcionará porque nunca he trabajado con base de datos en el sistema de ficheros, pero por probar que no quede.

Saludos.
Volver arriba

#13 - 18/06/2008 13:13:27 Reporta abuso | Link Permanente
Mecodi
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
hola otra vez:
El error anterior se corrige siguiendo pasos de:
http://www.devmedia.com.br/articles/viewcomp.asp?comp=5534

Pero ahora me sale el error:

No se pudo actualizar la base de datos "C:\INETPUB\WWWROOT\PFC\APP_DATA\ASPNETDB.MDF" porque es de sólo lectura.
¿Cómo lo puedo cambiar? Tengo que hacer algo en el SQL Server Mangement studio e incluirla junto con mi bd?
en el web.config tengo:
  <connectionStrings>
    <add name="DatabaseConnectionString1" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\Database.mdf;Integrated Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
    <add name="DatabaseConnectionString2" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\ASPNETDB.MDF;Integrated Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
  </connectionStrings>
 
un saludo.
Volver arriba

#14 - 18/06/2008 12:23:03 Reporta abuso | Link Permanente
Mecodi
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
Sigo exponiendo las soluciones y nuevos errores:
En IIS debes configurar esa carpeta como aplicación, si no ASP.NET no funciona. En Sitio web predeterminado, boton derecho, Nuevo directorio virtual, y ahi le dices donde está la carpeta... y bueno... sigue los pasos.
Pero me da el error al intentar loguearse en la página de inicio:
Error durante la compilación de un recurso requerido para dar servicio a esta solicitud. Revise los detalles de error específicos siguientes y modifique el código fuente en consecuencia.

Mensaje de error del compilador: CS0030: No se puede convertir el tipo 'ASP.login_aspx' en 'System.Web.UI.WebControls.Login'

Error de código fuente:

Línea 118:        public login_aspx() {
Línea 119:            string[] dependencies;
Línea 120:            ((Login)(this)).AppRelativeVirtualPath = "~/login.aspx";
Línea 121:            if ((global::ASP.login_aspx.@__initialized == false)) {
Línea 122:                dependencies = new string[4];
Alguien sabe a qué se debe? gracias y un saludo.
Volver arriba

#15 - 18/06/2008 11:47:35 Reporta abuso | Link Permanente
Mecodi
Usuario no registrado
RE: Error al publicar sitio web

Responder Citar
hola:
Encontré en otro foro esta solución.
REVISAR que IIS tenga configurada la misma version del framework .net
PASOS:
1) Inicio -> ejecutar -> CMD
2) Dirigirnos a la carpeta de la version del FrameWork que tengan en mi caso fue asi:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
3) teclear: aspnet_regiis.exe -i -enable
4) listo....el IIS les debería dejar reconocer las paginas en ASP.NET
PERO, sigue dándome este error:
Error de configuración
Descripción: Error durante el procesamiento de un archivo de configuración requerido para dar servicio a esta solicitud. Revise los detalles de error específicos siguientes y modifique el archivo de configuración en consecuencia.
Mensaje de error del analizador: Es incorrecto utilizar una sección registrada como allowDefinition='MachineToApplication' mas allá del nivel de aplicación. Este error puede tener como origen un directorio virtual que no esté configurado como aplicación en IIS.
Error de código fuente:
Línea 96:             durante la depuración.
Línea 97:         -->
Línea 98:     <authentication mode="Forms" />
Línea 99:     <compilation debug="true"/>
Línea 100:    <!--
A alguien se le ocurre a qué es debido?. un saludo
Volver arriba
Mostrar de en 15